Lab 2. iBGP Peer (Loopback) - NETBLOG

Lab 2. iBGP Peer (Loopback)

Lab 2. iBGP Peer (Loopback)

Pada post kali, kita masih mendalami salah satu materi CCIE yaitu BGP. Pada Lab kali ini saya akan membahas tentang iBGP Peer via Loopback. Apa perbedaannya dengan lab sebelumnya ???. Perbedaannya pada lab sebelumnya kita menggunakan interface physical untuk melakukan peering ke router lain, namun pada lab kali ini kita melakukan peer melalui interface logical atau loopback. Selain itu jika menggunakan interface loopback untuk perantara peering maka kita harus menjalankan sebuah IGP misalkan OSPF, ataupun EIGRP. Karena jika tidak menggunakan IGP, maka antar IP loopback setiap router tidak akan saling mengadvertise. Jika tidak terjadi maka iBGP yang kita buat tidak akan running. Untuk memperjelas sekarang kita langsung masuk ke topologi dan juga konfigurasi.
Konfigurasi di R1:
R1(config)#int fa0/0
R1(config-if)#no sh
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
Kemudian konfigurasikan routing IGP untuk mengadvertise network loopback. Disini saya akan menggunakan EIGRP.
R1(config)#router eigrp 2017
R1(config-router)#net 12.12.12.0 0.0.0.255
R1(config-router)#net 1.1.1.1 0.0.0.0
R1(config-router)#no aut
Konfigurasi di R2:
R2(config)#int fa0/0
R2(config-if)#no sh
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#int fa0/1
R2(config-if)#no sh
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
Kemudian lakukan hal yang sama seperti di R1, yaitu membuat routing IGP yang berguna untuk mengadvertise network loopback.
R2(config)#router eigrp 2017
R2(config-router)#net 12.12.12.0 0.0.0.255
R2(config-router)#net 23.23.23.0 0.0.0.255
R2(config-router)#net 2.2.2.2 0.0.0.0
R2(config-router)#no aut
Konfigurasi di R3:
R3(config)#int fa0/0
R3(config-if)#no sh
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
Kemudian buat routing IGP di R3.
R3(config)#router eigrp 2017
R3(config-router)#net 23.23.23.0 0.0.0.255
R3(config-router)#net 3.3.3.3 0.0.0.0
R3(config-router)#no aut
Setelah routing IGP kita buat, cobalah lakukan ping ke salah satu interface loopback.

R1#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/32 ms

Jika hasilnya sudah reply, sekarang lanjut ke konfigurasi BGP.

BGP di R1:
R1(config)#router bgp 18
R1(config-router)#neighbor 2.2.2.2 remote-as 18
R1(config-router)#neighbor 2.2.2.2 update-source lo0
R1(config-router)#neighbor 3.3.3.3 remote-as 18
R1(config-router)#neighbor 3.3.3.3 update-source lo0
BGP di R2:
R2(config)#router bgp 18
R2(config-router)#neighbor 1.1.1.1 remote-as 18
R2(config-router)#neighbor 1.1.1.1 update-source lo0
R2(config-router)#neighbor 3.3.3.3 remote-as 18
R2(config-router)#neighbor 3.3.3.3 update-source lo0
BGP di R3:
R3(config)#router bgp 18
R3(config-router)#neighbor 2.2.2.2 remote-as 18
R3(config-router)#neighbor 2.2.2.2 update-source lo0
R3(config-router)#neighbor 1.1.1.1 remote-as 18
R3(config-router)#neighbor 1.1.1.1 update-source lo0
Setelah kita melakukan peer ke network loopback masing-masing router, sekarang cek apakah BGP yang telah dikonfigurasikan running atau tidak.

R3#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 18
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4    18      19      19        1   0    0  00:15:19        0

Disini terlihat bahwa neighbor yang muncul pada BGP table adalah IP Loopback router tetangga.

Sekarang kita coba menambahkan beberapa network untuk diadvertise melalui BGP pada salah satu router.
Sebelum itu buat lagi interface loopback untuk network yang akan diadvertise melalui BGP.

R1:
R1(config)#int lo1
R1(config-if)#ip add 181.181.181.10 255.255.255.255
R1(config-if)#int lo2
R1(config-if)#ip add 200.200.200.10 255.255.255.255
Disini saya akan menambahkan network yang akan diadvertise melalui BGP di R1.

R1:
R1(config)#router bgp 18
R1(config-router)#net 181.181.181.10 mask 255.255.255.255
R1(config-router)#net 200.200.200.10 mask 255.255.255.255
Setelah itu cek di routing table salah satu router, apakah network yang ditambahkan itu telah masuk ke routing table atau belum.

R2:

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/32 is subnetted, 1 subnets
B       200.200.200.10 [200/0] via 1.1.1.1, 00:00:01
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/409600] via 12.12.12.1, 01:03:16, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/409600] via 23.23.23.3, 00:59:24, FastEthernet0/1
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet0/1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
     181.181.0.0/32 is subnetted, 1 subnets
B       181.181.181.10 [200/0] via 1.1.1.1, 00:00:04

R3:

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/32 is subnetted, 1 subnets
B       200.200.200.10 [200/0] via 1.1.1.1, 00:00:59
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/435200] via 23.23.23.2, 01:08:05, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 23.23.23.2, 01:08:05, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
D       12.12.12.0 [90/307200] via 23.23.23.2, 01:08:07, FastEthernet0/0
     181.181.0.0/32 is subnetted, 1 subnets
B       181.181.181.10 [200/0] via 1.1.1.1, 00:01:01 

Setelah itu coba lakukan test ping dari salah satu router, ke salah satu interface loopback yang baru dibuat tadi.

R3#ping 200.200.200.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.10, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/48/60 ms

Jika hasil test pingnya reply, maka BGP yang dibuat BERHASIL!!!


Selesaiii....



Previous
Next Post »