EIGRP Filtering
Okey guys, on this post i will explain about the features of EIGRP, that is EIGRP Filtering. EIGRP filtering is a features with the function to filter some network. EIGRP filtering can be configured with some methods. which among these:
1. Combine with Access List.
2. Use Distibute List.
3. Change the Administative Distance.
4. Use Prefix List to filter some network with the certain prefix.
First we will configure EIGRP Filtering with Distribute List, Let's check it out.
In this lab we use GNS3, if you haven't the cisco IoS for GNS3 you can also download the IoS in here.
Topology for this lab:
the scenario of this lab, the loopback network of R3 not found in routing table of R1.
First give IP Address to interface which directly connected to other router.
R1:
R1(config)# interface Loopback0R2:
R1(config-if)# ip address 1.1.1.1 255.255.255.255
R1(config-if)# interface Loopback1
R1(config-if)# ip address 1.1.1.2 255.255.255.255
R1(config-if)# interface Loopback2
R1(config-if)# ip address 1.1.1.3 255.255.255.255
R1(config-if)# interface FastEthernet0/0
R1(config-if)# ip address 12.12.12.1 255.255.255.252
R1(config-if)# no sh
R2(config)#int fa0/0R3:
R2(config-if)#no sh
R2(config-if)#ip add 12.12.12.2 255.255.255.252
R2(config-if)#int lo0
R2(config-if)#ip add 2.2.2.1 255.255.255.255
R2(config-if)#int lo1
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#int lo2
R2(config-if)#ip add 2.2.2.3 255.255.255.255
R2(config)#int fa0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no sh
R3(config)#int fa0/0after this we will make Dynamic routing protocol EIGRP in each router.
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int lo0
R3(config-if)#ip add 3.3.3.1 255.255.255.255
R3(config-if)#int lo1
R3(config-if)#ip add 3.3.3.2 255.255.255.255
R3(config-if)#int lo2
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R1:
R1(config-if)#router eigrp 1R2:
R1(config-router)#no auto-summary
R1(config-router)#net 12.12.12.0
R1(config-router)#net 1.1.1.1 0.0.0.0
R1(config-router)#net 1.1.1.2 0.0.0.0
R1(config-router)#net 1.1.1.3 0.0.0.0
R2(config)#router eigrp 1R3:
R2(config-router)#no auto-summary
R2(config-router)#net 12.12.12.0
R2(config-router)#net 23.23.23.0
R2(config-router)#net 2.2.2.1 0.0.0.0
R2(config-router)#net 2.2.2.2 0.0.0.0
R2(config-router)#net 2.2.2.3 0.0.0.0
R3(config)#router eigrp 1After that, Make sure that router mutually adjency already. For verifying you can check with the command, "do show ip route".
R3(config-router)#no aut
R3(config-router)#net 23.23.23.0
R3(config-router)#net 3.3.3.1 0.0.0.0
R3(config-router)#net 3.3.3.2 0.0.0.0
R3(config-router)#net 3.3.3.3 0.0.0.0
this an appreance of routing table at one router
If in routing table have a network with flag "D". That your sign that the router know the network by using routing protocol EIGRP.
Now we will filter that network on Interface Loopback at R3 not listed at routing table at R1.
First make an Access List to deny all network in Interface Loopback at R3, make an Access List on R1.
R1:
R1(config)#access-list 1 deny 3.3.3.1After make an Access List, now we will make a distribute list at R1.
R1(config)#access-list 1 deny 3.3.3.2
R1(config)#access-list 1 deny 3.3.3.3
R1(config)#access-list 1 permit any
R1:
R1(config)#router eigrp 1For verifying we can check the routing table at R1, whether network on Interface Loopback at R3 still listened at routing table at R1 or not.
R1(config-router)#distribute-list 1 in fa0/0
Here we can see ther network on interface loopback at R3 not listened at routing table R1. so, the distribute list configuration has been success.
Alright I think this enough, see you at next post. At next post we still exploring about routing protocol EIGRP. So, still stay at this blog.
And See you next Time.
Greetings, Networkers
ConversionConversion EmoticonEmoticon